Resolved
Slowness in cloud and document rendering

Started
September 13, 2021 at 4:04 PM
Status
Resolved after 23 minutes

Impact

Degraded performance
Affected
Document Rendering
Web app
  • Resolved
    September 13, 2021 at 4:27 PM

    We've confirmed the fix worked and everything is back to normal

  • Resolved
    September 13, 2021 at 4:20 PM

    We've applied a fix and are monitoring the status.

  • Investigating
    September 13, 2021 at 4:04 PM

    We are currently investigating this incident.