Resolved
Cloud slowness

Started
December 15, 2022 at 3:04 PM
Status
Resolved after less than a minute

Impact

Degraded performance
Affected
Web app
  • Resolved
    December 15, 2022 at 3:04 PM

    Latency numbers for the cloud are back to normal