All systems operational

Show current status

[Resolved] Sketch Cloud affected by global network issues

Started on August 30, 2020 at 10:17 AM. Resolved after about 5 hours

Affected

Sketch Cloud
  • Monitoring
    August 30, 2020 at 10:17 AM  –  

    We are being adversely affected by the ongoing global network issues. As a result, some documents could fail to render correctly.

  • Resolved
    August 30, 2020 at 2:56 PM  –  

    Global network issues solved, we have been monitoring performance and everything is back to normal.