All systems operational

[Resolved] Degraded performance

Started on July 7, 2020 at 8:21 AM. Resolved after less than a minute

Affected

Sketch Cloud
  • Resolved
    July 7, 2020 at 8:21 AM

    Cloud platform could be slow or unresponsive. Our engineers have identified the problem and are working on a fix.