Show current status

[Resolved] Degraded performance due to high load

Started on March 30, 2020 at 3:50 PM. Resolved after about 2 hours

Affected

Sketch Cloud
  • Investigating
    March 30, 2020 at 3:50 PM  –  

    Our systems are under high load and users can experience long waiting times for document rendering.

    We are currently investigating the issue.

  • Resolved
    March 30, 2020 at 5:30 PM  –  

    The problem has ben identified and fixed.