All systems operational

Show current status

[Resolved] Degraded performance

Started on March 18, 2020 at 12:08 PM. Resolved after less than a minute

Affected

Sketch Cloud
  • Resolved
    March 18, 2020 at 12:08 PM  –  

    We are having problems with the cloud platform. User experience can be affected.