All systems operational

[Resolved] Degraded performance due to high load

Started on March 2, 2020 at 4:32 PM. Resolved after about 2 hours

Affected

Sketch Cloud
  • Investigating
    March 2, 2020 at 4:32 PM

    Our systems are under high load and users can experience long waiting times for document rendering.

    We are currently investigating the issue.

  • Resolved
    March 2, 2020 at 6:37 PM

    The issue has been resolved.