All systems operational

Show current status

[Resolved] Degraded performance

Started on October 20, 2020 at 12:59 PM. Resolved after about 3 hours

Affected

Sketch Cloud
  • Investigating
    October 20, 2020 at 12:59 PM  –  

    Cloud platform could be slow or unresponsive. Our engineers are investigating the possible cause.

  • Resolved
    October 20, 2020 at 4:00 PM  –  

    Our engineers have identified and fixed the issue. The cloud service is operating normally.