All systems operational

Resolved
Users may experience errors and delays in the cloud application due to an AWS outage

Started
June 13, 2023 at 7:14 PM
Status
Resolved after about 2 hours

Impact

Major outage
Affected
Web app
Document Rendering
Collab
  • Resolved

    This incident has been resolved.

  • Identified

    We're monitoring the situation