All systems operational

Resolved
Slow rendering in cloud documents

Started
October 30, 2023 at 1:44 PM
Status
Resolved after about 3 hours

Impact

Degraded performance
Affected
Document Rendering
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We are currently investigating this incident.